Issues with storing snapshots
Incident Report for Happo
Resolved
This incident has been resolved. The cause of the issue was a deploy we made last night (updating Safari, Chrome and Firefox to the latest versions). When saving a screenshot, we first check to see if the same image has already been stored. If so, we can avoid writing it to disk. There's a cache involved here when checking to see if the image was already present. This cache was partially broken, causing an error to be thrown under certain circumstances. A fix was made right away and we've rolled it out to all of our infrastructure.
Posted Nov 14, 2022 - 13:17 UTC
Investigating
We are seeing elevated errors related to storing screenshots. We're investigating and hope to have an update soon!
Posted Nov 14, 2022 - 10:55 UTC
This incident affected: Workers (Chrome, Firefox, Edge, Safari, Internet Explorer, iOS Safari, iOS Safari (iPad)).