Microsoft workers unavailable
Incident Report for Happo
Resolved
The workers are back online and in good health. Sorry for the disruption!
Posted Jun 15, 2022 - 17:32 UTC
Investigating
Our cluster of Edge and Internet Explorer workers is currently down. We are doing our best to bring it back online as quickly as possible!
Posted Jun 15, 2022 - 17:17 UTC
This incident affected: Workers (Edge, Internet Explorer).