Elevated queue times
Incident Report for Happo
Resolved
Queue times are back to normal again.
Posted Sep 01, 2022 - 19:22 UTC
Investigating
We are currently investigating long queue times for chrome and ipad-safari targets.
Posted Sep 01, 2022 - 16:17 UTC
This incident affected: Workers (Chrome, iOS Safari (iPad)).