Increased error rates for snap-request jobs

Incident Report for Happo

Resolved

We have found the root cause of this issue now. A temporary fix is currently active and we are soon to deploy a proper fix. The issue was caused by a stale cache that caused snap-request jobs to not save properly.
Posted Jun 02, 2025 - 20:17 UTC

Investigating

We are investigating an issue with snap-requests randomly failing with a `HTTP error 404: http://happo-view-service/api/snap-requests/:id/payload -- Not Found` error.
Posted Jun 02, 2025 - 19:05 UTC
This incident affected: API.